[Developers] "configure" in trunc

John Sibert sibert at hawaii.edu
Tue Jan 3 10:25:48 PST 2012

Regarding make: The there value of N in make -j N is best left 
installation-dependent since it depends on hardware. On a core duo 
machine, make -j 4 launches 4 processes in parallel. On the PFRP 
workstation, make -j 16 launches 16 processes.  For my own work, I set 
up an alias in my .bashrc file on each machine to do the right thing, e.g.
alias make='make -j4'
alias make='make -j16'
When I run any procedure involving make, it launches the maximum number 
of processes that the hardware supports. Problems sometimes occur when 
there are errors making it difficult to know which process caused the 
error. When that occurs, I can override the alias by typing make -j1.

Regarding the configure script: It is generated by the default makefile. 
Step 3 in README.txt advises:
> 3. Create configure script
>    $ make --directory=scripts/configure/
The configure scripts then creates GNUmakefile according to the options 
specified (including BUILD_64BIT=yes) which is invoked by make to build 
the libraries.

I hope this clarifies things a bit.

On 01/02/2012 09:45 PM, Hans J. Skaug wrote:
> Followup:
> My confusion under 2) is that my trunk already contains
> a "configure" which appears to be different from the one Dave wants (attached).
> So the question is why Dave does not get that when he checks out the
> the trunk.
> Hans
>> -----Original Message-----
>> From: developers-bounces at admb-project.org [mailto:developers-
>> bounces at admb-project.org] On Behalf Of Hans J. Skaug
>> Sent: Tuesday, January 03, 2012 8:35 AM
>> To: developers at admb-project.org
>> Subject: [Developers] "configure" in trunc
>> Developers,
>> The Redmine link on the ADMB homepage is not working:
>> http://admb-project.org/redmine/
>> Otherwise I would put in the following issue about make files there.
>> The following issues come from Dave:
>> 1. Include " -j 4 option as in" to make compilation faster.
>> 2. Missing confiugre file:
>>> If I run the command
>>> svn checkout http://www.admb-project.org/svn/trunk
>>> there is no configure file in trunk although the README file says
>>> or configure the build files for 64-bit.
>>>     $ ./configure BUILD_64BIT=yes
>>> This works if I copy the configure file from the
>>> zip archive.
>> Hans
>> _______________________________________________
>> Developers mailing list
>> Developers at admb-project.org
>> http://lists.admb-project.org/mailman/listinfo/developers

John Sibert
Emeritus Researcher, SOEST
University of Hawaii at Manoa

Visit the ADMB project http://admb-project.org/

More information about the Developers mailing list